Brink Errors, Crashes, ATI, No Sound, Freezes, FPS Fix


Brink (PC) has just been released and seems like there are few issues that need Splash Damage’s attention. I won’t whine about these issues rather talk about how you can fix these and experience smooth gameplay.

In this Brink Troubleshooting Guide, I have explained how you can fix general errors, crashes and other problems. Most importantly how to Fix ATI performance issues, and how to tweak the game for best performance and increase your FPS.

Note. Use all thread’ cvars workarounds with caution, they may negatively impact the performance of the game.
1# Brink (PC) ATI Driver HotFix
First turn on in-game console. For this go to your steam library and find brink. Right click and choose properties. The on the General tab select SET LAUNCH OPTIONS and add this.

+com_allowconsole 1

Start up brink and open the console with tilde key, and type ‘r_shadows 0′ without quotes.

After this tweak. Download and install the latest ATI HotFix Drivers.

2# Brink Multiplayer Servers Not Responding, Connection Issues and Server Joining Problem
Forward these ports and you will be able to connect to servers just fine.

UDP/TCP 27015, 27016 and 8766

How to Port Forward

Detailed Guide on how you can forward your ports for all the multiplayer games.
Note: May not work for all routers but will provide a basic outline on how you should go about forwarding your ports.

Step 1
Go to the “Run” in start menu and type “cmd” (without quotes) and click OK. See Example

Step 2

Next a black window will pop up. Type “ipconfig” (without quotes) and hit enter. See Example

Step 3
List of words and numbers will pop up. You will only need the Default Gateway IP Address and the IPv4 Address IP Adress.
Default Gateway
IPv4 Address

Step 4
Open your web browser and type the Default Gateway IP address in the address of your web browser and hit enter. See Example

Step 5
For the user name type in “admin” (without quotes) and the password you either leave blank or type in “password” (without quotes) or “admin”. You can use portfowarding.com to check more about your router. See Example

Step 6
After logging in, on the right you should see an option for Port Forwarding/Port Triggering. Click it. See Example

Step 7
Now click on “Add service” and you should see a few fields like service name, service type, starting port, ending port and server IP address.

Service Name: Add any name you want.
Service Type: Leave as is TCP/UDP
Starting Port: Put 27015
Ending Port: Put 27016
Server IP Address: Put the IPv4 Address in. See Example

Step 8
After that hit apply and then add another service, but in the starting and ending port fields put “8766”. Your services should look like this now.

Go Play!

3# Brink – Blue Screen of Death Fix
This issue has been fixed with the latest patch but if still persists, you can do the following workaround.
Delete the generated folder from ‘\…\Users\#user#\AppData\Local\splash damage\brink\base\’.

4# Brink – Crash at Desktop/Start Up
First off, make sure you aren’t missing any file. Verify the integrity of the game cache in Steam. Once it’s done. Try to launch the game, it still doesn’t resolve disable tripple buffering.

5# OpenGL driver lost connection with the display driver
Make sure you have updated the game to latest patch. If the issue still persists follow the workaround below. You can also try to lower the resolution.

Go to your BRINK profile (or use the global profile) in the nVidia driver panel and set “Power Management Mode” from “adaptive” to “prefer maximum performance”.

6# Brink Error creating game rendering context
If on start up you are receiving “Error creating game rendering context”, and the only option you have is to quit. If you are using nVidia card, Disable Triple Buffering and If you are using ATI card, try the hotfix above.

7# Brink – No Sound/ Sound Issues
If you are experiencing any of these two Sound issues:
1. All the sound disappears, except for ambient environmental sounds (radio music, machinery, thunder, etc.). The sounds often play fine when the next map loads.
2. All/most sound plays, but the volume levels for different sounds aren’t quite right (e.g. grenades being quieter)

The issue is usually solved when the game loads a different map (or possibly when reloading the same map when disconnecting and then reconnecting back into the same server).

8# Brink – Low FPS and Performance
Install the latest ATI hotfix pr nVidia Updated Drivers which address these issues.
Disable Motion Blue.
Disable Shadows.
Disable Triple Buffering.
Optimize the game for multi cores using this console tweak:
seta r_useThreadedRenderer “2”

9# Game Freezes at Save The Arc, Escape The Arc Screen

10# Brink – Texture Bugs, Graphics Issue

11# Brink – Grid Effect and Blue Tinted Screen
This issue is associated with people running the game on ATI video card. Refer to ATI Fix to resolve this issue.

12# How to Skip Intro Movies
Simply rename your assets folder.

Steam\steamapps\common\brink\base\video\assets

13# How to Change FOV
In the console type ui_fov XX. Where XX is your FOV; default (and lowest) is 70.

14# Temporary Fix For 30 FPS Lock in Brink Singleplayer
Go into Steam tools, and install the dedicated server. Once you’ve setup the Brink Dedicated Server, Create a Config file in C:\Program Files (x86)\Steam\steamapps\common\brink dedicated server\base to start the campaign mode, or challenge map.

[Sample config.cfg]
si_rules sdGameRulesCampaign
applyServerConfig Standard
spawnServer mp/aquarium
campaign set campaign_resistance
g_password password [[CHANGE THIS]]
net_serverAllowHijacking 0
si_playMode 1
si_onlineMode 2
si_needpass 1
si_maxRank 4
si_botDifficulty 2
[End Sample]

Once the file is created, launch Brink, then alt-tab out, launch the server using brink_ded.bat, and in the console use “exec config.cfg”

Go back into brink, join your server, either via LAN, or direct connect 127.0.0.1, enter the password from above, and enjoy.

15# Sound Causes Game Stuttering
As suggested above, Install and Update DirectX drivers to resolve this issue.

16# Brink Low FPS – 30 FPS Lock
In singleplayer games, Brink by default caps the FPS to 30. If you want to experience the smoother gameplay, try the tweak in #14.

17# Brink Multiplayer PC Lag Fix
Disable Ambient Occlusion and it will resolve this issue. If you are using an ATI Video card, try the Drivers HotFix listed above. Brink has recently released an update which addresses this issue, you may want to try that as well.

18# Brink Server Browser Lag Fix
Browse to your C:\Program Files (x86)\Steam\userdata and search for:

serverbrowser_hist.vdf

Delete it! to fix server browser lag.

19# The OpenGL driver doesn’t support
Update your video cards drivers, and run DirectX.

If you face any other issues, let us know and we will try to help you out. Please do provide feedback to the devs on official forum so they can investigate these issues further.

Word by Developer – Lead Tester ‘Crispy’ from Splash Damage
For the most up-to-date information and our word on which workarounds are recommended, please visit the Splash Damage Tech Support forums where we are engaging with the community to investigate issues and feed back advice.

By Zawad Iftikhar

Zawad is the lead editor of SegmentNext. He primarily manages what gets published on the site. He is a finance student and PC games enthusiast.

Latest Posts

Around The Network
    • satyajeet

      please tell me the solution on fc.chk fetal error

    • satyajeet

      how to fix fc.chk fatal error

    • Demon

      I normally do not post on these because the information given works or at least tries to fix the issue. I have read every word on this page and I have tried the steps that are given. Knowing the year is 2012 knowing that ATI has released 12.6 and 12.7 beta drivers I would say the ATI issue is fixed. I installed this game first time today and gave it a shot. I installed all game updates minus the dlc. I created a character and I tried the first mission. After 5 minutes of playing the game crashed with a fatal error saying something about allocat or what ever. After trying so hard to trouble shoot this issue I gave up. I read this page and trust me what is posted great information but it is also incorrect or not for every one. The question I wonder is did the company splash damage released a patch or fix or update that fixes this issue yet? Or is this one of those games that are broken and you just have to say fuck it?

    • sh3rifff
    • alvin

      i cnnot open my download games?

    • alvin

      its ok for me?

    • Cyberpirate

      How to fix #9 Save the Ark or Escape the Ark freeze???????????? Please I need to know the solve!!!!!!!!!!!

    • Orange Cry

      I followed every instructions but still I can’t play campaign + freeplay mode at all…(somehow i manage to play few freeplay modes…weird).
      I can only play challenge only OTL
      How can fix this problem???
      Help Me plz

    • annoymous

      Waiting for a response
      Pls someone help me
      I really like the game but the spots are driving me crazy…. :)

    • annoymous

      I have a completely different problem.Everything works fine except that when I shoot someone black spots appear on that place.Even when my allies shoot black spots appear.I have 2 gb ram 1 gb nvidia Graphic card.Please respond fast

    • annoymous

      I have a completely different problem.Everything works fine except that when I shoot someone black spots appear on that place.Even when my allies shoo black spots appear.I have 2 gb ram 1 gb nvidia Graphic card

    • adagamer

      when i want to customize my character the game always freeze and not responding . you know why ? i’m using ATI 5670 .

    • Othergrif

      can someone please help i’ve looked all over the internet for someone the same problem as me but i could not find anyone so can some one please help. It comes up with the brink loading screen then it go’s away and then come back for a second the a box comes up just for a second just long a so know it’s there like a flash. then it comes up with an error. the error is
      the current video card/driver combination does not support openGL 3.1 or newer
      —— Initializing File System ——
      Loaded pak000.sdpk2
      Loaded pak001.sdpk2
      Loaded pak002.sdpk2
      Loaded pak003.sdpk2
      Loaded pak004.sdpk2
      Loaded pak005.sdpk2
      Loaded pak006.sdpk2
      Loaded pak007.sdpk2
      Loaded zzzdlcenglish000.sdpk2
      Loaded zzzenglish000.sdpk2
      Loaded zzzenglish001.sdpk2
      Loaded zzzenglish002.sdpk2
      Loaded zzzenglish003.sdpk2
      Loaded zzzenglish004.sdpk2
      Loaded zzzenglish005.sdpk2
      Loaded zzzenglish006.sdpk2
      Current search path:
      C:\Users\griffin\Saved Games\steam\userdata\87104578\22350\local/base
      C:\Users\griffin\AppData\Local\Splash Damage\Brink/base
      c:\users\griffin\saved games\steam\steamapps\common\brink/base
      zzzenglish006.sdpk2
      zzzenglish005.sdpk2
      zzzenglish004.sdpk2
      zzzenglish003.sdpk2
      zzzenglish002.sdpk2
      zzzenglish001.sdpk2
      zzzenglish000.sdpk2
      zzzdlcenglish000.sdpk2
      pak007.sdpk2
      pak006.sdpk2
      pak005.sdpk2
      pak004.sdpk2
      pak003.sdpk2
      pak002.sdpk2
      pak001.sdpk2
      pak000.sdpk2
      file system initialized.
      ————————————–
      Loaded 3783 manifest elements in 11 ms – 192Kb
      Discarded 0 manifest elements
      Max filename length: 0 characters
      Brink 1.0.23653.48097 win-x86 Jul 29 2011 11:29:57
      couldn’t exec ‘brinkconfig.cfg’
      couldn’t exec ‘autoexec.cfg’
      Vendor: 8086 Device: 2E22
      2494 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
      4 logical cores
      4 physical cores
      HT disabled in hardware
      4064 MB System Memory
      1806 MB Video Memory
      Initializing performance queries
      Detected
      4 2.49 GHz CPU
      4064 MB of System memory
      1806 MB of Video memory on an optimal video architecture

      This system qualifies for High quality!
      Vendor: 8086 Device: 2E22
      Winsock Initialized
      Found interface: {2FB65928-5121-4F94-BDEA-505845051222} Intel(R) 82567V-2 Gigabit Network Connection – 10.0.1.2/255.255.255.0
      Found interface: {54528CAA-E944-4244-8E0A-3224B14C1723} VMware Virtual Ethernet Adapter for VMnet1 – 192.168.153.1/255.255.255.0
      Found interface: {A17A4CDA-16A1-434E-8055-B28360D32DB8} VMware Virtual Ethernet Adapter for VMnet8 – 192.168.40.1/255.255.255.0
      Sys_InitNetworking: adding loopback interface
      — Loading sequence: init —
      sound index file ‘generated/preload/sound/pc/english/init.soundpreload’ is zero length
      ——- Initializing render context ——–
      Initializing OpenGL subsystem
      …calling LoadLibrary( ‘wtsapi32.dll’ ): succeeded
      …initializing Windows Terminal Server API
      …registered window class
      …registered fake window class
      …calling LoadLibrary( ‘opengl32′ ): succeeded
      …initializing QGL
      GL_VENDOR: Intel
      GL_RENDERER: Intel(R) G45/G43 Express Chipset
      GL_VERSION: 2.1.0 – Build 8.15.10.2302
      ********************
      FATAL ERROR: The current video card / driver combination does not support OpenGL 3.1 or newer.
      ********************
      The current video card / driver combination does not support OpenGL 3.1 or newer.
      Shutting down OpenGL subsystem
      …releasing DC
      …resetting display
      …shutting down QGL
      …unloading OpenGL DLL
      …unloading Windows Terminal Server API DLL

      I don’t know what type of video card i have or how to tell and i have tried installing penGL 3.1 but have no idea how and could not find a download link. Thank you

      • Raymond

        I have the same problem how do we fix this?

    • MAGF0357

      Man, my brink don’t have any sound! how do i fix it? =/

    • LouisJay

      help. I installed ati hotfix, but it crashes during the brink logo… any other ways to fix the fps of brink? i want to play this game. :(

      • LouisJay

        sorry is AMD hotfix

    • Xsite

      For Sound Problem just go to Brink folder and launch /directx/DXSETUP
      it worked for me!

    • Sinan

      Hey i have a question. When i started the game i cant see any script on the buttons i have to choose. i dont know which button in the game the campaign or online or settings button is…Can anybody help me ??

    • reinhazen

      yea i got that problem too. but mine is smg_light
      aw man.. i hate this!

      • Kashif

        it’s all d same……….
        jst changes filenimes……

    • BaaRoth

      for those who got some sound problemes i found somthing that works for me
      try to install Dx sdk here http://www.microsoft.com/downloads/en/details.aspx?familyid=2da43d38-db71-4c1b-bc6a-9b6652cd92a3

      it fix my sound probleme

      Good luck

    • DeadMen

      When i play brink….The brink server error come automatically….so i when i read your solution…I’d try to hotfix the ati cause i’m using ati graphics card…actually i can’t understand that,what means you “HOTFIX ABOVE”…..plz Help.

    • NETOS

      I NEED HELP PLEASE!!
      FATAL ERROR: AllocRenderModel called from a different thread for ‘particles/weapons/muzzle_flashes/smg_heavy’
      ********************
      mouse: Failed to remove raw input device
      …unloading Raw Input DLL

      ——- Input Initialization ——-
      Initializing DirectInput8…
      …calling LoadLibrary( ‘user32.dll’ ): succeeded
      …initializing Raw Input
      mouse: Raw Input initialized.
      …calling LoadLibrary( ‘imm32.dll’ ): succeeded
      …initializing Input Method Editor
      ————————————
      AllocRenderModel called from a different thread for ‘particles/weapons/muzzle_flashes/smg_heavy’
      mouse: Failed to remove raw input device
      …unloading Raw Input DLL
      Shutting down OpenGL subsystem
      …releasing DC
      …destroying window
      …shutting down QGL
      …unloading OpenGL DLL
      …unloading Windows Terminal Server API DLL
      I DONT KNOW WHAT TO DO!!!!

      • http://segmentnext.com Zawad Iftikhar

        Do you meet minimum requirements for graphics card ? shader model etc ? and try updating DirectX and video card drivers.

        • NETOS

          I have the last update for my graphic card (ATI RADEON SERIES 1GB GDDR5 HD 5750)
          I am starting the game and then when I am on the first mission the game crashes and then appears a window (Brink Server) and writes :
          “FATAL ERROR: AllocRenderModel called from a different thread for ‘particles/weapons/muzzle_flashes/ironsight_fast’
          ********************
          mouse: Failed to remove raw input device
          …unloading Raw Input DLL

          ——- Input Initialization ——-
          Initializing DirectInput8…
          …calling LoadLibrary( ‘user32.dll’ ): succeeded
          …initializing Raw Input
          mouse: Raw Input initialized.
          …calling LoadLibrary( ‘imm32.dll’ ): succeeded
          …initializing Input Method Editor
          ————————————
          AllocRenderModel called from a different thread for ‘particles/weapons/muzzle_flashes/ironsight_fast’
          mouse: Failed to remove raw input device
          …unloading Raw Input DLL
          Shutting down OpenGL subsystem
          …releasing DC
          …destroying window
          …shutting down QGL
          …unloading OpenGL DLL
          …unloading Windows Terminal Server API DLL”

          • Kashif

            hey man i 2 hv d same prob…..
            i hv updated my nvidia drivers 2 270.61 wich is d latest….
            my specs r …
            2 GB RAM..
            NVIDIA 9400 GT 512 MB……
            Core 2 Duo 2.4 GHz…
            WIN XP SP3….
            plss help me…
            i hv waited a long time 4 dis game…
            i can’t even play 4 10 mins b4 d fuckin’ server screen comes up…….

            • Kashif

              Finished compositing contextId 18 team resistance (1) cinematic: false
              Spent 127ms waiting
              Spent 481ms total
              Finished compositing contextId 19 team resistance (1) cinematic: false
              Spent 270ms waiting
              Spent 695ms total
              Finished compositing contextId 20 team resistance (1) cinematic: false
              — Completed loading sequence in 13.21s —
              —– idSoundCache::EndLevelLoad —–
              _vmtrpages: locked 1106846 bytes (8.44 cache lines) in physical image, 0 cache lines in disk cache
              maps/mp/aquarium: locked 295080 bytes (2.25 cache lines) in physical image, 0 cache lines in disk cache
              Virtual textures loaded and locked in 0.17s
              0: ‘aqrint_csc’ StopCutscene…
              …precaching anims for actor: ( maps/mp/aquarium.entities ) aqrint_actor_1
              …precaching anims for actor: ( maps/mp/aquarium.entities ) aqrint_actor_2
              …precaching anims for actor: ( maps/mp/aquarium.entities ) aqrint_actor_3
              …precaching anims for actor: ( maps/mp/aquarium.entities ) aqrint_player
              0: ‘aqsint_csc’ StopCutscene…
              0: ‘aqoutro_csc’ StopCutscene…
              0: ‘aqmid_csc’ StopCutscene…
              === Allow user to skip loading screen ===
              ———————————–
              00:13 to load maps/mp/aquarium.entities
              sdAbilityManager::OnLocalPlayerClassChanged: 0
              Received abilities from client 0
              …’grenade_molotov’ set as bind 0
              …’landmine’ set as bind 8
              …’charge’ set as bind 16
              …’spotting’ set as bind 17
              …’repairing’ set as bind 18
              …’disarming’ set as bind 19
              …’building’ set as bind 20
              …’revive’ set as bind 21
              …’hacking’ set as bind 22
              …’sprinting_reload’ set as bind 23
              …’give_ammo’ set as bind 56
              …’life_buff1′ set as bind 57
              …’weapon_buff1′ set as bind 58
              …’disguise_self’ set as bind 59
              14 abilities set
              done setting 14 local abilities
              All Stats Cleared
              OnIntroCutsceneStart
              99: Cinematic (correct) model for ‘aqrint_actor_1′ composited (uses id 1, expected id 1), ccfIndex 9
              99: Cinematic (correct) model for ‘aqrint_actor_2′ composited (uses id 2, expected id 2), ccfIndex 10
              99: Cinematic (correct) model for ‘aqrint_actor_3′ composited (uses id 3, expected id 3), ccfIndex 11
              99: Non-cinematic (correct) model for ‘aqrint_player’ composited (uses id -1, expected id -1), ccfIndex 0
              OnIntroCutsceneEnd
              Player Team: resistance
              Fade in victory splash
              All Stats Cleared
              All Stats Cleared
              WARNING: Thread ”: Already synced stats less than a minute ago – ignoring
              Mapscripts: setup objective from match state
              …OnMatchStatePrimary 0
              …OnMatchStateOther 0 0
              …OnMatchStateOther 1 0
              …OnMatchStateOther 2 0
              …OnMatchStateOther 3 0
              …OnMatchStateOther 4 0
              …OnMatchStateOther 5 0
              …OnMatchStateOther 6 0
              …OnMatchStateOther 7 0
              …OnMatchStateOther 8 0
              …OnMatchStateOther 9 0
              …OnMatchStateOther 10 0
              …OnMatchStateOther 11 0
              …OnMatchStateOther 12 0
              …OnMatchStateOther 13 0
              …OnMatchStateOther 14 0
              …OnMatchStateOther 15 0
              …OnMatchStateOther 16 0
              …OnMatchStateOther 17 0
              Mapscripts: done setting up objective from match state
              8 mins to go
              client 15 connected.
              OnClientConnect: Clearing abilities for client 15
              Syncing match state to client 15
              WARNING: Thread ”: GetNetVarFloat: ‘assault_rifle_02_reload_complete_fraction’ 0.890000 clamped to 0.875000 (min: 0.0000 max: 0.8750)
              client 14 connected.
              OnClientConnect: Clearing abilities for client 14
              Syncing match state to client 14
              client 13 connected.
              OnClientConnect: Clearing abilities for client 13
              Syncing match state to client 13
              client 12 connected.
              OnClientConnect: Clearing abilities for client 12
              Syncing match state to client 12
              WARNING: Thread ”: GetNetVarFloat: ‘pistol_04_reload_complete_fraction’ 0.890000 clamped to 0.875000 (min: 0.0000 max: 0.8750)
              Finished compositing contextId 1 team resistance (1) cinematic: false
              client 11 connected.
              OnClientConnect: Clearing abilities for client 11
              Syncing match state to client 11
              Finished compositing contextId 3 team resistance (1) cinematic: false
              Finished compositing contextId 2 team resistance (1) cinematic: false
              client 10 connected.
              OnClientConnect: Clearing abilities for client 10
              Syncing match state to client 10
              client 9 connected.
              OnClientConnect: Clearing abilities for client 9
              Syncing match state to client 9
              client 8 connected.
              OnClientConnect: Clearing abilities for client 8
              Syncing match state to client 8
              TASK SELECT (Kashif): Attempting Primary: ‘snd_destroy_guard_select’ (owner: ‘tank_doors’)
              client 7 connected.
              OnClientConnect: Clearing abilities for client 7
              Syncing match state to client 7
              WARNING: Thread ”: GetNetVarFloat: ‘assault_rifle_02_reload_complete_fraction’ 0.890000 clamped to 0.875000 (min: 0.0000 max: 0.8750)
              client 6 connected.
              OnClientConnect: Clearing abilities for client 6
              Syncing match state to client 6
              WARNING: Thread ”: GetNetVarFloat: ‘assault_rifle_02_reload_complete_fraction’ 0.890000 clamped to 0.875000 (min: 0.0000 max: 0.8750)
              client 5 connected.
              OnClientConnect: Clearing abilities for client 5
              Syncing match state to client 5
              WARNING: Thread ”: GetNetVarFloat: ‘assault_rifle_02_reload_complete_fraction’ 0.890000 clamped to 0.875000 (min: 0.0000 max: 0.8750)
              client 4 connected.
              OnClientConnect: Clearing abilities for client 4
              Syncing match state to client 4
              WARNING: Thread ”: GetNetVarFloat: ‘pistol_04_reload_complete_fraction’ 0.890000 clamped to 0.875000 (min: 0.0000 max: 0.8750)
              client 3 connected.
              OnClientConnect: Clearing abilities for client 3
              Syncing match state to client 3
              client 2 connected.
              OnClientConnect: Clearing abilities for client 2
              Syncing match state to client 2
              client 1 connected.
              OnClientConnect: Clearing abilities for client 1
              Syncing match state to client 1
              WARNING: Thread ”: GetNetVarFloat: ‘pistol_02_reload_complete_fraction’ 0.890000 clamped to 0.875000 (min: 0.0000 max: 0.8750)
              Resetting bot skills…
              Bot skills reset
              WARNING: Bot 5 failed to perform objective buff_player_health because of time expiration limits when performing (bot action index: -1)
              Migration other match state 1: 1
              Migration other match state 2: 2
              Security skill bumped up, Resistance down
              tracked globals.game.commandPostActivetracked globals.game.commandPostActiveMigration other match state 5: 2
              WARNING: RES1004: Invalid input data – sdDeclAnimStateMachine: player/legs: State ‘MountedDefault’ has no transitions, machine is stuck
              WARNING: RES1004: Invalid input data – sdDeclAnimStateMachine: player/torso: State ‘MountedDefault’ has no transitions, machine is stuck
              ********************
              FATAL ERROR: AllocRenderModel called from a different thread for ‘particles/weapons/impacts/metal’
              ********************
              mouse: Failed to remove raw input device
              …unloading Raw Input DLL

              ——- Input Initialization ——-
              Initializing DirectInput8…
              …calling LoadLibrary( ‘user32.dll’ ): succeeded
              …initializing Raw Input
              mouse: Raw Input initialized.
              …calling LoadLibrary( ‘imm32.dll’ ): succeeded
              …initializing Input Method Editor
              ————————————
              AllocRenderModel called from a different thread for ‘particles/weapons/impacts/metal’
              mouse: Failed to remove raw input device
              …unloading Raw Input DLL
              Shutting down OpenGL subsystem
              …releasing DC
              …destroying window
              …shutting down QGL
              …unloading OpenGL DLL
              …unloading Windows Terminal Server API DLL
              dis is wat i get……

    • powahnewb

      every time i join any map (except challenges) the screen turns blue and I still hear the movement of my character but i can only barely make out the map i can only use few things as landmarks so i bumble around the map the entire time i don’t know why this is happening because in some places the screen randomly turns normal but it spends 90 percent of the time blue

    • MidnighT

      please i need help with *9

    • ilegal

      i have a don’t send problem…..can someone tell me a solution for this problem?

    • cinder43

      Did #1 work for anyone? I tried it but it didn’t work. I can’t get the console open, no matter what I do it still just brings up the vid card/driver error.

      • http://segmentnext.com Zawad Iftikhar

        It has been recommended by Splash Damage and if you have the issue with nVidia ATI Video Card, it probably should.

        • cinder43

          Im confused about the console part, I’ve typed in the command for allow console but nothing comes up except for the error about the vid card. What am I missing? How do I access the area to type in the shadow command?

    • Michailov

      If peiople still suffer from horrid lag after trying the 11.5 ATI hotfix
      and all the above.
      Deleting your VideoDrivers and going back to 11.2 fixes it all.

    • jeff

      how do you forward the ports?? I have no idea how to do that and i am getting kicked from servers constantly :(

      • http://segmentnext.com Zawad Iftikhar

        I have added the detailed guide in the article. Check!

    • underdog

      its unlayable with these grids

    • joseph

      My game wont start up and i have made sure triple buffering isn’t on. I have absolutely no idea on what to do. can someone please help…. please lol

    • xryz

      How do you take a command of the console? i put one in game and now my game wont start its the “seta r_useThreadedRenderer 2

    • Yodawg

      11# Brink – Grid Effect and Blue Tinted Screen
      This issue is associated with people running the game on ATI video card. Refer to ATI Fix to resolve this issue.

      this will take forever…

    • jonny

      #9….plsss heeellllp

    • Patrick

      I’m having the same issue as a lot of people, with problem #6. I turned off Triple Buffereing and the problem still persists. I want to try the solution in #1, but something doesn’t seem to be right. How am I supposed to open the console for the game if the game never starts up?

      I added the start up run line to the game, I run the game, and it goes start to the error screen afer about 30 secs. So when am I supposed to push the ~ key? How can I change the shadow settings for the game if I can never get the game to actual open?

      • Sokosan

        I have got an ati 4650 gpu
        I couldnt start the game even if I tried gpu updates etc.
        The only thing I saw is a splash screen and an error message

    • Tod

      I got number 1 problem and it doesnt works please help….i still get high FPS

    • Zzyzzy

      I have an imac 27″ with ATI 4850 and the “AMD Catalyst 11.5a hotfix” and latest windows 7 64 bit update installed. I made an autoexec.cfg as written upside in order to make BRINK working at 2560×1440 full screen and it works (also better than 1920×1080). Afterall i have to confirm that the GRID ISSUE still persist. I am wondering if at Spash damage they only test games on Nvidia cards. I confirm also that Ambient Occlusion drops fram rate drammatically and that i can’t see difference using the command “ seta r_useThreadedRenderer “2” “. I have a 2.8 i7 QuadCore but.. is this command for multiple CPU or GPU ?? PLEASE FIND A SOLUTION FOR THE GRID. I HATE IT.

    • Karait

      Guys, regarding #3 are you sure it should be this way? Shouldn’t it be “0”s if I want to disable Motion Blur and HQPostProcess?

      • http://segmentnext.com Zawad Iftikhar

        Yeah, replace 1 with 0 to disable these.

      • http://segmentnext.com Zawad Iftikhar

        May bad, a typo.

    • Wade

      I am experiences #6. I disabled triple buffering on my Nvidia Control Panel, but it still happens. Please god help.

    • bismark1217

      Im having issues with #6. i have a nVidia card, but i do not know were to do to turn off triple buffer.

    • spire2

      Found a solution that worked for me. Installed dxsetup.exe in the Brink install folder and then restarted. Now I’m playing with 0 problems. Read it at the link below:

      http://www.splashdamage.com/forums/showthread.php?p=295333

      • h3X

        Confirmed here, fixed my sound too!

    • Dakata

      When i start my game , the mouse doesnt work.

      • stinkfist

        Mine does too…I tried to reinstall DX and tweak custom settings but nothing

    • spire2

      How do you “run the game in stereo”? I have no sound and don’t understand this instruction.

      • http://segmentnext.com Zawad Iftikhar

        Open your Realtek Audio Control Manager and under Speaker Configuration Choose Stereo from the drop down menu. Click OK. Re-launch the game. (PC)

        • spire2

          I can open my Realtek HD Audio Manager and choose 2CH Speaker from the drop down menu. No options for stereo, though. I’ve even updated my drivers!

          • http://segmentnext.com Zawad Iftikhar

            Go Control Panel > Hardware and Sound > Sound > Choose Your Speakers and Click Configure on Left Bottom. See if now you can see the Stereo option ? and Tell me your detailed specs.

            • spire2

              Motherboard: ASUSTeK Computer INC. P5QPL-AM

              CPU: Intel Core2 Quad CPU Q8300@2.50GHz

              RAM: Corsair 1GB DDR2 PC2-5300 (2)

              Sound: Realtek HD Audio output

              Video: ATI Radeon HD 5670

              OS: Windows XP Pro SP3 (Build 2600)

            • spire2

              Oh, and I’ve found and confirmed the Stereo option is selected.

            • h3X

              I have absolutely no sound in the game, my sound works perfectly outside the game, and all settings are already at stereo. Is there anything else I can do but pray?

    • Dodo

      I enabled antialiasing in-game and through config by setting r_useantialiasing “1”, but the game still looks as if no antialiasing is used, all the textures seem “jagged”.
      Any fix or console command that enables or multiplies AA levels?

      • Dodo

        If i try to force AA via ATI Catalyst Control Center, the hangs @ startup.. end process is required.

        • Joe

          I believe the correct usage of r_useantialiasing is:

          r_useantialiasing 2
          r_useantialiasing 4
          r_useantialiasing 8
          r_useantialiasing 16

          Pick the one you want

    • Sean

      Ok, so I am not the best when it comes to computers, and I am experienceing number 4. Could someone please explain what to do here? Thanks

      • http://segmentnext.com Zawad Iftikhar

        OK – Open up your nVidia control Panel and under Manager 3D Settings which you can choose from left, set Triple Buffering to Off. Apply the new settings. Let me know if it helped you.

    • l3lackl2eaper

      Ya ummm the Ati driver fix does not fix the Grid Effect stupid 4xxx

      • http://segmentnext.com Zawad Iftikhar

        This is a problem with ATI Drivers and sadly there is no fix yet.

    • Ben

      I’m not tech savy. tried looking it up. When I try and open the console, I get the error “Another game instance is already running. Use win_allowMultipleInstances to force”

      • http://segmentnext.com Zawad Iftikhar

        What are you actually trying to do ? You are trying to launch the console ? or open in-game dev console ?

        • Ben

          I get the “Error creating game rendering context” and am confused about what to do.

          • poop

            i have the same problem please help

    • areamike

      Tried all the fixes but the gmae still crashes right after the splash screen appears for a second. AMD DUO 2.5GHZ, 4GB Memory, ATI Radeon 4670. Time for a refund!

      • progz

        Its because you added

        “seta r_useThreadedRenderer 2″ in you autoconfig.cfg

        I added it then my game crashed once it started too. I deleted the command and it works fine now. no crashes.

        • areamike

          No I didn’t. I don’t even know where that file is. I have no modified any files.

          • Hulle107

            Hmm, I got same problem, I can’t startup the game, say something about a program is running and it shutdown the game…

            Have try it all, whet no luck.

            Please help us…

    • Bo

      Is there a 11.5a hotfix for vista? It only says XP and windows 7.

      • http://segmentnext.com Zawad Iftikhar

        Use the one For Windows 7. Most of the drivers for both Vista/Windows 7 are same, So I am hoping here it would work for you.

    • Naiboss

      Fantastic job… hopefully this will get more people playing!

    • LoneWanderer

      Is there any way to force custom resolution? I need 1600×945, but Brink only supports 1600×900…

      • http://segmentnext.com Zawad Iftikhar

        You can force the resolution on the game through the steam but I am not sure how it will work out.

        Right click on ‘Brink’ in Steam -> Properties -> Set launch options.
        Add “-w 1600 -h 945 -refresh 60″. Run the game, and change video settings in game options to this resolution and refresh rate.

        • Stele

          That only works with source games.

          For Brink you need an autoexec.cfg in the steam/userdata/#/22350/local/base folder.

          For his 16×9, he would want:

          seta r_mode "-1"
          seta r_fullscreen "0"
          seta r_customWidth "1600"
          seta r_customHeight "900"
          seta r_aspectRatio "1"
          seta r_customAspectRatioH "16"
          seta r_customAspectRatioV "9"

          Or change fullscreen to 1 if he wants fullscreen on. Just copy/paste that into a text file and rename it autoexec.cfg and bam.

          • Stele

            Er sorry, I see he meant 945. Need an edit button.

            So might have to change the last part about aspectratio as well. Do some math. :D

            Just like r_mode “-1″, the -1 means custom, so aspectratio might have to be -1 as well, then he can do custom h/v.

          • http://segmentnext.com Zawad Iftikhar

            Thanks for correction.

      • http://www.splashdamage.com/forums/forumdisplay.php?f=37 Crispy

        Lead Tester from Splash Damage here:

        While your work is commendable and we appreciate the efforts of our community, some of these workarounds are no longer necessary (fixed in patches) and some can potentially negatively impact the performance and stability of the game (e.g. any ‘thread’ cvars).

        For the most up-to-date information and our word on which workarounds are recommended, please visit the Splash Damage Tech Support forums where we are engaging with the community to investigate issues and feed back advice.

        • http://segmentnext.com Zawad Iftikhar

          I have updated the article with latest recommended workarounds. Thanks for stopping by.

          • http://www.splashdamage.com/forums/forumdisplay.php?f=37 Crispy

            Thanks for the speedy reponse! ;)

            • Jon

              Crispy, how can you let such a broken game go to release?? I am still in awe seeing how many problems there are with this game. What a joke. Personally, I am dealing with the connection issues that everyone else seems to be dealing with. The port forwarding does not work. For Christs sake, not only can i not play online, I cannot play via LAN either. Total disgrace.

              Sincerely,
              Disappointed Customer

              • http://segmentnext.com Zawad Iftikhar

                Please specify your issue at the official forum. They are really trying their best to resolve every issue the customers are facing. For me the game runs OK and after few patches, the experience has been improved.

                P.S. I have also deliberately not reviewed the game yet since I don’t want to give half arsed opinion on a game that can be fixed with few more patches. There is nothing in this game that can’t be fixed.