<!doctype html>
<html lang="en-US">
	<head>
		<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="http://gmpg.org/xfn/11">
		
	<!-- This site is optimized with the Yoast SEO Premium plugin v15.8.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Destiny 2 At Your Fingertips Exotic Quest Guide | SegmentNext</title>
	<meta name="description" content="In this Destiny 2 At Your Fingertips guide, we have the complete At Your Fingertips mission walkthrough for you to dig through." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Destiny 2 At Your Fingertips Exotic Quest Guide | SegmentNext" />
	<meta property="og:description" content="In this Destiny 2 At Your Fingertips guide, we have the complete At Your Fingertips mission walkthrough for you to dig through." />
	<meta property="og:url" content="https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/" />
	<meta property="og:site_name" content="SegmentNext" />
	<meta property="article:publisher" content="http://facebook.com/segmentnext" />
	<meta property="article:published_time" content="2021-02-25T16:15:48+00:00" />
	<meta property="og:image" content="https://cdn.segmentnext.com/wp-content/uploads/2021/02/Destiny-2-At-Your-Fingertips-e1614269740517.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="629" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@segmentnext" />
	<meta name="twitter:site" content="@segmentnext" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Talal">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="2 minutes">
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SegmentNext &raquo; Feed" href="https://segmentnext.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SegmentNext &raquo; Comments Feed" href="https://segmentnext.com/comments/feed/" />
			<meta property="og:title" content="Destiny 2 At Your Fingertips Exotic Quest Guide">
			<meta property="og:type" content="article">
			<meta property="og:url" content="https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/">
			<meta property="og:site_name" content="SegmentNext">
							<meta property="og:description" content="Gaming News, Reviews, PC Hardware and eSports">
							<meta property="og:image" content="https://cdn.segmentnext.com/wp-content/uploads/2021/02/Destiny-2-At-Your-Fingertips-e1614269740517.jpg">
			<link rel="alternate" type="application/rss+xml" title="SegmentNext &raquo; Destiny 2 At Your Fingertips Exotic Quest Guide Comments Feed" href="https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdn.segmentnext.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=1611674313"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='segment-next-style-css'  href='https://cdn.segmentnext.com/wp-content/themes/segmentnext/style.css?ver=1614144420' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.segmentnext.com/wp-includes/css/dist/block-library/style.min.css?ver=1613571386' type='text/css' media='all' />
<link rel='stylesheet' id='aksile-silo-css'  href='https://cdn.segmentnext.com/wp-content/plugins/aksile-silo/public/css/aksile-silo-public.css?ver=1614144420' type='text/css' media='all' />
<link rel='stylesheet' id='segmentnext-core-css'  href='https://cdn.segmentnext.com/wp-content/plugins/segmentnext-core/public/css/segmentnext-core-public.css?ver=1614144420' type='text/css' media='all' />
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/jquery/jquery.min.js?ver=1602088405' id='jquery-core-js'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1605778273' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-content/plugins/aksile-silo/public/js/aksile-silo-public.js?ver=1614144420' id='aksile-silo-js'></script>
<link rel="https://api.w.org/" href="https://segmentnext.com/wp-json/" /><link rel="alternate" type="application/json" href="https://segmentnext.com/wp-json/wp/v2/posts/714904" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://segmentnext.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.segmentnext.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://segmentnext.com/?p=714904' />
<link rel="alternate" type="application/json+oembed" href="https://segmentnext.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsegmentnext.com%2F2021%2F02%2F25%2Fdestiny-2-at-your-fingertips-exotic-quest%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://segmentnext.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsegmentnext.com%2F2021%2F02%2F25%2Fdestiny-2-at-your-fingertips-exotic-quest%2F&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://segmentnext.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/' + 'LhfdY3JSwVQ8' + '.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script><!-- Google Analytics -->
<script type="text/javascript">
	(function (i, s, o, g, r, a, m) {
		i['GoogleAnalyticsObject'] = r;
		i[r] = i[r] || function () {
			(i[r].q = i[r].q || []).push(arguments)
		}, i[r].l = 1 * new Date();
		a = s.createElement(o),
				m = s.getElementsByTagName(o)[0];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore(a, m)
	})(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');

	ga('create', 'UA-4104257-2', 'auto');
	  ga('set', 'dimension1', 'talal-waseem');
  ga('set', 'dimension2', 'Destiny 2');
	ga('send', 'pageview');
</script>
<!-- /Google Analytics -->

<!-- Yandex.Metrika counter -->
<script type="text/javascript" >
	(function (d, w, c) {
		(w[c] = w[c] || []).push(function() {
			try {
				w.yaCounter50618239 = new Ya.Metrika2({
					id:50618239,
					clickmap:true,
					trackLinks:true,
					accurateTrackBounce:true,
					webvisor:true
				});
			} catch(e) { }
		});

		var n = d.getElementsByTagName("script")[0],
			s = d.createElement("script"),
			f = function () { n.parentNode.insertBefore(s, n); };
		s.type = "text/javascript";
		s.async = true;
		s.src = "https://mc.yandex.ru/metrika/tag.js";

		if (w.opera == "[object Opera]") {
			d.addEventListener("DOMContentLoaded", f, false);
		} else { f(); }
	})(document, window, "yandex_metrika_callbacks2");
</script>
<noscript><div><img src="https://mc.yandex.ru/watch/50618239" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<!-- /Yandex.Metrika counter -->
			<!-- Venatus Ad Manager - Install in <HEAD> of page -->
		<script>
		(function() {
		document.write('<div id="vmv3-ad-manager" style="display:none"></div>');
		document
		.getElementById("vmv3-ad-manager")
		.innerHTML = '<iframe id="vmv3-frm" src="javascript:\'<html><body></body></html>\'" width="0" height="0" data-mode="scan" data-site-id="5e3bdf5b48105f3605472aeb"></iframe>';
		var loaderFrame = document.getElementById("vmv3-frm");
		var loaderFrameWindow = loaderFrame.contentWindow ? loaderFrame.contentWindow : loaderFrame.contentDocument;
		loaderFrameWindow.document.open();
		loaderFrameWindow.document.write('<scr'+'ipt src="https://hb.vntsm.com/v3/live/ad-manager.min.js" type="text/javascript" async>'+'</scr'+'ipt>');
		loaderFrameWindow.document.close();
		})();
		</script>
		<!-- Venatus Ad Manager -->
				<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
		<script>
			var googletag = googletag || {};
			googletag.cmd = googletag.cmd || [];
		</script>
			<!-- Taboola -->
	<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
		if (!document.getElementById(i)){
		e.async = 1;
		e.src = u;
		e.id = i;
		f.parentNode.insertBefore(e, f);
		}
		}(document.createElement('script'),
				document.getElementsByTagName('script')[0],
				'//cdn.taboola.com/libtrc/segmentnext/loader.js',
				'tb_loader_script');
		if (window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic'); }
	</script>
	<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><!-- There is no amphtml version available for this URL. --><link rel="icon" href="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.carousel-num { width: 100px; }		</style>
		<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Destiny 2 At Your Fingertips Exotic Quest Guide",
    "image": "https:\/\/cdn.segmentnext.com\/wp-content\/uploads\/2021\/02\/Destiny-2-At-Your-Fingertips-e1614269740517.jpg",
    "datePublished": "2021-02-25",
    "dateModified": "2021-02-25",
    "description": "At Your Fingertips is the newest quest available in Destiny 2. This quest follows the last week\u2019s quest Presage, in which you obtained the Dead Man\u2019s Tale Exotic Rifle. In this Destiny 2 At Your Fingertips guide, we have the complete At Your Fingerti",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "id": "https:\/\/segmentnext.com\/2021\/02\/25\/destiny-2-at-your-fingertips-exotic-quest\/"
    },
    "author": {
        "@type": "Person",
        "name": "Talal"
    },
    "publisher": {
        "@type": "Organization",
        "name": "SegmentNext",
        "url": "https:\/\/segmentnext.com",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/cdn.segmentnext.com\/wp-content\/uploads\/2020\/01\/cropped-segment-next.png"
        }
    }
}</script>
	</head>
	<body class="post-template-default single single-post postid-714904 single-format-standard wp-custom-logo">
			<div id="page" class="site">
			<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
			<header id="masthead" class="site-header">
				<nav id="site-navigation" class="navbar navbar-default">
					<div class="container-fluid">
						<!-- Brand and toggle get grouped for better mobile display -->
						<div class="navbar-header">
							<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#primary-navbar-collapse" aria-expanded="false">
								<i class="icon icon-menu"></i>
								<i class="icon icon-close"></i>
							</button>
							<div class="search-container mobile hidden-lg">
								<div class="search-box">
									<form role="search" method="get" id="search-form" action="https://segmentnext.com/">
										<div class="input-group">
											<input type="text" name="s" class="form-control search-field" placeholder="Search &hellip;" aria-describedby="sizing-addon1">
											<span class="input-group-btn">
												<button class="navbar-search go" type="submit"><i class="icon icon-enter"></i></button>
												<button class="navbar-search open-search" type="button"><i class="icon icon-search"></i></button>
											</span>
										</div>
									</form>
								</div>
							</div>
							<a href="https://segmentnext.com/" class="navbar-brand" rel="home"><img width="395" height="70" src="https://cdn.segmentnext.com/wp-content/uploads/2020/01/cropped-segment-next.png" class="custom-logo" alt="SegmentNext" /></a>						</div>
						<!-- Collect the nav links, forms, and other content for toggling -->
						<div class="collapse navbar-collapse" id="primary-navbar-collapse">
							<ul id="menu-header-navbar-left" class="nav navbar-nav"><li><a title="News" target="_blank" href="https://segmentnext.com/topics/news/">News</a></li>
<li><a title="Reviews" target="_blank" href="https://segmentnext.com/topics/reviews/">Reviews</a></li>
<li><a title="Computer Hardware" target="_blank" href="https://segmentnext.com/topics/computer-hardware/">Computer Hardware</a></li>
</ul>														<a href="https://segmentnext.com/topics/deals/" class="btn btn-sm btn-transparent btn-block navbar-btn visible-xs visible-sm btn-ghost-dark fill-animate ghost-fill shutter-horizontal">Best Deals</a>
														<div class="nav navbar-nav navbar-right search-container visible-lg">
								<div class="search-box">
									<form role="search" method="get" id="search-form" action="https://segmentnext.com/">
										<div class="input-group">
											<input type="text" name="s" class="form-control search-field" placeholder="Search &hellip;" aria-describedby="sizing-addon1">
											<span class="input-group-btn">
												<button class="navbar-search go" type="submit"><i class="icon icon-enter"></i></button>
												<button class="navbar-search open-search" type="button"><i class="icon icon-search"></i></button>
											</span>
										</div>
									</form>
								</div>
							</div>
														<a href="https://segmentnext.com/topics/deals/" class="btn btn-sm btn-transparent navbar-btn navbar-btn-desktop navbar-right hidden-xs hidden-sm btn-ghost-dark fill-animate ghost-fill shutter-horizontal">Best Deals</a>
							
							<ul id="menu-header-top-menu" class="nav navbar-nav navbar-right extra-links"><li><a title="Esports" target="_blank" href="https://segmentnext.com/topics/esports/">Esports</a></li>
<li><a title="Pop Culture" target="_blank" href="https://segmentnext.com/topics/pop-culture/">Pop Culture</a></li>
</ul>							<ul class="nav navbar-nav navbar-right social-icons">
								<li><a href="https://twitter.com/@segmentnext" target="_blank"><i class="icon icon-twitter-circle"></i></a></li>
								<li><a href="https://facebook.com/SegmentNext" target="_blank"><i class="icon icon-facebook-circle"></i></a></li>
								<li><a href="https://www.youtube.com/user/segmentnext" target="_blank"><i class="icon icon-youtube"></i></a></li>
							</ul>
						</div><!-- /.navbar-collapse -->
					</div><!-- /.container-fluid -->
				</nav><!-- #site-navigation -->
			</header><!-- #masthead -->

			
			<div id="content" class="site-content">
				<div class="container">
			<div class="ad-atf-top single">
			<div class="ad-atf-top-single-dimension">
				<!-- segmentnext.com - 728x90 Dynamic (5e3be75e48105f3605472aed) - 728x90, 970x250, 970x90 - Place in <BODY> of page where ad should appear -->
				<div class="vm-placement" data-id="5e3be75e48105f3605472aed"></div>
				<!--/ segmentnext.com - 728x90 Dynamic (5e3be75e48105f3605472aed) -->
			</div>
		</div>
	
			<div class="visible-sm visible-md visible-lg"><ul class="breadcrumb"><li><a href="https://segmentnext.com/topics/guides/">Guides</a></li><li><a href="https://segmentnext.com/topics/guides/destiny-2/">Destiny 2</a></li></ul></div>
	
			<h1 class="entry-title desktop visible-sm visible-md visible-lg">Destiny 2 At Your Fingertips Exotic Quest Guide</h1>	
	<div class="row">
		<div class="col-md-8">
			<div id="primary" class="content-area">
				<main id="main" class="site-main">
					
					<div class="feature-image hidden-xs">
				<div class="post-thumbnail">
				<img width="1200" height="629" src="https://cdn.segmentnext.com/wp-content/uploads/2021/02/Destiny-2-At-Your-Fingertips-e1614269740517.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Destiny 2 At Your Fingertips Exotic Quest" loading="lazy" />			</div><!-- .post-thumbnail -->
		</div>

<article id="post-714904" class="post-714904 post type-post status-publish format-standard has-post-thumbnail category-destiny-2 tag-destiny-2 tag-destiny-2-guide">
	<div class="entry-item-container">
		<header class="entry-header visible-sm visible-md visible-lg">
				<div class="entry-meta">
		<span class="byline"> By <span class="author"><a class="url fn n" href="https://segmentnext.com/author/talal-waseem/">Talal</a></span></span><span class="posted-on"><a href="https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-25T21:15:48+05:00" itemprop="datePublished">Feb 25, 2021</time></a></span>		<span class="share dropdown">
			<a href="javascript:void(0);" class="btn btn-xs btn-primary fill-animate default-fill shutter-horizontal dropdown-toggle shareBtn" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false" aria-labelledby="dropdownMenu1"><span class="icon icon-share"></span> Share</a>
			<div class="dropdown-menu share-box dropdown-menu-right">
				<div class="top-section">
					<h6>Share</h6>
										<ul class="list-inline mb-0 px-0">
						<li class="list-item"><a target="_blank" href="http://www.facebook.com/share.php?u=https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/" class="share-link facebook"><i class="icon icon-facebook"></i></a></li>
						<li class="list-item"><a target="_blank" href="http://twitter.com/home?status=Destiny%202%20At%20Your%20Fingertips%20Exotic%20Quest%20Guide - https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/" class="share-link twitter"><i class="icon icon-twitter"></i></a></li>
						<li class="list-item"><a target="_blank" href="http://reddit.com/submit?url=https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/&#038;title=Destiny%202%20At%20Your%20Fingertips%20Exotic%20Quest%20Guide" class="share-link redit"><i class="icon icon-redit"></i></a></li>
						<li class="list-item"><a target="_blank" href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/&#038;title=Destiny%202%20At%20Your%20Fingertips%20Exotic%20Quest%20Guide" class="share-link linkdin"><i class="icon icon-linkedin-open"></i></a></li>
					</ul>
				</div>
				<div class="mid-section">
					<input class="form-control" type="text" value="https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/" placeholder="link ..." id="copyInput" autofocus="autofocus" onfocus="this.select()" readonly=""/>
				</div>
				<div class="bottom-section clearfix">
					<button class="btn btn-link btn-sm pull-right copy-permalink" type="button" id="copyID">Copy</button>
				</div>
			</div>
		</span>
	</div>
			</header><!-- .entry-header -->
		<div class="entry-content">
			
			<p>At Your Fingertips is the newest quest available in Destiny 2. This quest follows the last week’s quest Presage, in which you obtained the Dead Man’s Tale Exotic Rifle. In this Destiny 2 At Your Fingertips guide, we have the complete At Your Fingertips mission walkthrough for you.</p>
<h2>Destiny 2 At Your Fingertips Exotic Quest</h2>
<p>In order to start this exotic quest, you will first need to complete the last week’s exotic quest Presage.</p>
<p>After you complete that quest and get the <a href="https://segmentnext.com/2021/02/17/how-to-get-dead-mans-tale-in-destiny-2/">Dead Man’s Tale Exotic Rifle</a> as a reward, you will be able to start At Your Fingertips quest.</p>
<p>To start this quest, visit Zavala and talk to him to start the quest. This mission will be of Master Difficulty and requires a power level of 1320.</p>
<p>You will have to return to Glykon for this quest. This quest is essentially the Presage quest again, but on a much higher difficulty.</p>
<p>The mission will be the same as the Presage mission but with much tougher enemies and modifiers to make your life more difficult.</p><section class="ad ad-after-paragraph"><div class="ad-after-paragraph-dimension"><div class="vm-placement" data-id="5e3be76f48105f3605472aef"></div></div></section>
<p>The mission also has a time limit of 25 minutes, meaning that you will have to complete the mission within the time limit.</p>
<p>The mission will also lock your loadout once you enter the arena, so choose your preferred weapons before entering the battlefield.</p>
<p>Once you complete the mission, you will be rewarded with the Catalyst for the Dead Man’s Tale Exotic Rifle.</p>
<p>The catalyst provides Dark-Forged Trigger perk to the exotic rifle. It increases hip fire rate of the rifle and also removes the accuracy penalty when you hip fire using the Dead Man’s Exotic Rifle.</p>
<p>However, you will need to activate the Catalyst before being able to use it.</p>
<h3>How to activate the Catalyst for Dead Man’s Tale</h3>
<p>To activate the Catalyst for the Dead Man’s Tale exotic rifle, you need to kill a total of 800 enemies with the Dead Man’s Tale exotic rifle.</p><section class="ad ad-after-paragraph"><div class="ad-after-paragraph-dimension"><div class="vm-placement" data-id="5e3be76f48105f3605472aef"></div></div></section>
<p>You can also find hidden caches in the Presage mission to be able to use the catalyst. We have listed the 2 hidden caches with their locations below.</p>
<p><strong>Hidden Cache #1<br />
</strong>The cache can be discovered soon after the starting spacewalk. Head left when you enter the ship tunnels and use the first vent to find the datapad.</p>
<p>Use it to open the door close, and get the cache.</p>
<p><strong>Hidden Cache #2<br />
</strong>The second cache can be discovered not long before you arrive at the boat. You will discover another datapad on the floor that will open a vent in the floor behind you.</p>
<p>Drop down to get the cache.</p>

			<!--
			<section class="social-share visible-xs btm">
				<ul>
					<li><h6>Share This:</h6></li>
					<li><a target="_blank" href="http://www.facebook.com/share.php?u=" class="share-link facebook"><i class="icon icon-facebook"></i></a></li>
					<li><a target="_blank" href="http://twitter.com/home?status= - " class="share-link twitter"><i class="icon icon-twitter"></i></a></li>
					<li><a target="_blank" href="http://reddit.com/submit?url=&#038;title=" class="share-link redit"><i class="icon icon-redit"></i></a></li>
					<li><a target="_blank" href="http://www.linkedin.com/shareArticle?mini=true&#038;url=&#038;title=" class="share-link linkdin"><i class="icon icon-linkedin-open"></i></a></li>
				</ul>
			</section>
			-->
					</div><!-- .entry-content -->
	</div>
	</article><!-- #post-714904 -->

						<!-- Author Box -->
						<div class="author-box">
	<div class="author-box-content">
		<div class="row">
			<div class="col-md-3">
				<div class="avatar">
					<img alt='' src='https://secure.gravatar.com/avatar/77f37d7a7bca153d1790d406e04905a2?s=60&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/77f37d7a7bca153d1790d406e04905a2?s=120&#038;d=retro&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' loading='lazy'/>				</div>
				<div class="author">
					<div class="name">
					<a href="https://segmentnext.com/author/talal-waseem/" title="Talal" rel="me">Talal</a>					</div>
				</div>
				<div class="author-social-icons">
					
					
									</div>
			</div>

			<div class="col-md-9">
							</div>
		</div>
	</div>
</div>
						<!--/ Author Box -->

						<!-- Aksile Silo Menu -->
												<!--/ Aksile Silo Menu -->

						<!-- Related Articles -->
												<!--/ Related Articles -->

						
						
						<div id="taboola-below-article-thumbnails"></div>
						<script type="text/javascript">
							window._taboola = window._taboola || [];
							_taboola.push({
								mode: 'thumbnails-a',
								container: 'taboola-below-article-thumbnails',
								placement: 'Below Article Thumbnails',
								target_type: 'mix'
							});
						</script>
										</main><!-- #main -->
			</div><!-- #primary -->
		</div><!-- .col-md-8 -->
		<div class="col-md-4">
			<aside id="secondary" class="widget-area" role="complementary">
        <section id="segmentnext_widget_desktop_ad-6" class="widget widget_segmentnext"><!-- segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) - 300x250, 300x600, 160x600 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e3be77b48105f3605472af1"></div>
<!-- / segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) --></section><section id="segmentnext_widget-9" class="widget widget_segmentnext"><h4 class="widget-title"><span class="widget-title-before"><span class="widget-title-after">Reviews</span></span></h4>		<ul>
						<li>
				<a href="https://segmentnext.com/2021/01/17/scott-pilgrim-vs-the-world-complete-edition-review/">
										Scott Pilgrim vs The World: Complete Edition Review &#8211; A Victorious Return				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/11/30/immortals-fenyx-rising-review/">
										Immortals Fenyx Rising Review &#8211; A Fun Open World That Fails to Stand Out				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/11/24/godfall-review/">
										Godfall Review &#8211; Enjoyable Until You Start Noticing Its Flaws				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/11/23/observer-system-redux-review/">
										Observer System Redux Review &#8211; Twisted To Its Core				</a>
			</li>
								</ul>
		</section><section id="segmentnext_widget_desktop_ad-7" class="widget widget_segmentnext"><!-- segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) - 300x250, 300x600, 160x600 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e3be77b48105f3605472af1"></div>
<!-- / segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) --></section><section id="segmentnext_widget-10" class="widget widget_segmentnext"><h4 class="widget-title"><span class="widget-title-before"><span class="widget-title-after">Originals</span></span></h4>		<ul>
						<li>
				<a href="https://segmentnext.com/2021/02/18/ride-4-producer-next-gen/">
										Ride 4 Producer Discusses 60FPS/4K Standards, Next-Gen Power Differences, DualSense, More				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2021/02/09/last-epoch-multiplayer/">
										Last Epoch Dev Talks About Multiplayer, Ray Tracing, Competing With Diablo 4 And PoE 2				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2021/01/20/star-wars-fallen-order-2-ubisoft/">
										What Does Ubisoft&#8217;s New Star Wars Game Mean for Fallen Order 2?				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/12/21/sherlock-holmes-chapter-one-gameplay/">
										Sherlock Holmes Chapter One Gameplay Offers New Mechanics, More Freedom, Over 30 Side Missions				</a>
			</li>
								</ul>
		</section><section id="segmentnext_widget_desktop_ad-8" class="widget widget_segmentnext"><!-- segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) - 300x250, 300x600, 160x600 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e3be77b48105f3605472af1"></div>
<!-- / segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) --></section>
		<section id="recent-posts-2" class="widget widget_recent_entries">
		<h4 class="widget-title"><span class="widget-title-before"><span class="widget-title-after">In the News</span></span></h4>
		<ul>
											<li>
					<a href="https://segmentnext.com/2021/02/25/black-ops-cold-war-outbreak-pack-a-punch-machine/">Black Ops Cold War Outbreak Pack a Punch Machine Guide</a>
									</li>
											<li>
					<a href="https://segmentnext.com/2021/02/25/persona-5-strikers-dire-shadows/">Persona 5 Strikers Dire Shadows Guide</a>
									</li>
											<li>
					<a href="https://segmentnext.com/2021/02/25/need-for-speed-hot-pursuit-remastered-4k-60fps/">Need For Speed: Hot Pursuit Remastered Now Does 4K/60FPS On PS5 And Xbox Series X</a>
									</li>
											<li>
					<a href="https://segmentnext.com/2021/02/25/destiny-2-at-your-fingertips-exotic-quest/" aria-current="page">Destiny 2 At Your Fingertips Exotic Quest Guide</a>
									</li>
					</ul>

		</section>    </aside><!-- #secondary -->		</div><!-- .col-md-4 -->
	</div><!-- .row -->
</div><!-- .container -->
						</div><!-- #content -->
			<footer id="colophon" class="site-footer">
				<div class="container">
					<div class="row">
						<div class="col-md-8">
							<div class="logo-footer"><img src="https://cdn.segmentnext.com/wp-content/themes/segmentnext/images/segment-next.png" alt="SegmentNext" /></div>
							<div class="menu-footer">
								<h6 class="text-uppercase">Aksile Media</h6>
								<div class="menu-footer-menu-3-container"><ul id="footer-menu" class="menu"><li id="menu-item-421461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-421461"><a target="_blank" rel="nofollow" href="https://segmentnext.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-436385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-436385"><a target="_blank" rel="nofollow" href="https://segmentnext.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-436387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-436387"><a target="_blank" rel="nofollow" href="https://segmentnext.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-421463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-421463"><a target="_blank" rel="nofollow" href="https://segmentnext.com/contact-us/">Contact</a></li>
</ul></div>							</div>
							<div class="site-info">
								&copy; 2018 SegmentNext. All rights reserved.							</div><!-- .site-info -->
						</div><!-- #col-md-8 -->
						<div class="col-md-4">
							<div class="footer-right">
								<!--
									<h6 class="text-uppercase">< ?php _e('Stay Updated', 'segmentnext'); ?></h6>
									<h2>< ?php _e('SegmentNext Daily', 'segmentnext'); ?></h2>
									<p>< ?php _e('Signup for video game news, reviews and best gaming deals.', 'segmentnext'); ?></p>
								-->
								<h6 class="text-uppercase">Connect With Us</h6>

								<ul class="nav navbar-nav footer-socials social-icons">
									<li><a href="https://twitter.com/@segmentnext" target="_blank"><i class="icon icon-twitter-circle"></i></a></li>
									<li><a href="https://facebook.com/SegmentNext" target="_blank"><i class="icon icon-facebook-circle"></i></a></li>
									<li><a href="https://www.youtube.com/user/segmentnext" target="_blank"><i class="icon icon-youtube"></i></a></li>
								</ul>
							</div>
						</div><!-- #col-md-4 -->
					</div><!-- #row -->
				</div>
			</footer><!-- #colophon -->
		</div><!-- #page -->
	<!-- segmentnext.com - Rich Media AP (5e590016db8f36673d6188b1) - 1x1 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e590016db8f36673d6188b1" style="display:none"></div>
<!-- / segmentnext.com - Rich Media AP (5e590016db8f36673d6188b1) -->
	<script type='text/javascript' id='segment-next-scripts-js-extra'>
/* <![CDATA[ */
var global_var = {"ajaxurl":"https:\/\/segmentnext.com\/wp-admin\/admin-ajax.php","siteurl":"https:\/\/segmentnext.com\/wp-content\/themes\/segmentnext","nonce":"9f7c4f3d27","posts":"{\"page\":0,\"year\":2021,\"monthnum\":2,\"day\":25,\"name\":\"destiny-2-at-your-fingertips-exotic-quest\",\"error\":\"\",\"m\":\"\",\"p\":0,\"post_parent\":\"\",\"subpost\":\"\",\"subpost_id\":\"\",\"attachment\":\"\",\"attachment_id\":0,\"pagename\":\"\",\"page_id\":0,\"second\":\"\",\"minute\":\"\",\"hour\":\"\",\"w\":0,\"category_name\":\"\",\"tag\":\"\",\"cat\":\"\",\"tag_id\":\"\",\"author\":\"\",\"author_name\":\"\",\"feed\":\"\",\"tb\":\"\",\"paged\":0,\"meta_key\":\"\",\"meta_value\":\"\",\"preview\":\"\",\"s\":\"\",\"sentence\":\"\",\"title\":\"\",\"fields\":\"\",\"menu_order\":\"\",\"embed\":\"\",\"category__in\":[],\"category__not_in\":[],\"category__and\":[],\"post__in\":[],\"post__not_in\":[],\"post_name__in\":[],\"tag__in\":[],\"tag__not_in\":[],\"tag__and\":[],\"tag_slug__in\":[],\"tag_slug__and\":[],\"post_parent__in\":[],\"post_parent__not_in\":[],\"author__in\":[],\"author__not_in\":[],\"ignore_sticky_posts\":false,\"suppress_filters\":false,\"cache_results\":false,\"update_post_term_cache\":true,\"lazy_load_term_meta\":true,\"update_post_meta_cache\":true,\"post_type\":\"\",\"posts_per_page\":25,\"nopaging\":false,\"comments_per_page\":\"100\",\"no_found_rows\":false,\"order\":\"DESC\"}","current_page":"1","max_page":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-content/themes/segmentnext/js/sn-scripts.js?ver=1614144420' id='segment-next-scripts-js'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/comment-reply.min.js?ver=1611674313' id='comment-reply-js'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-content/plugins/segmentnext-core/public/js/segmentnext-core-public.js?ver=1614144420' id='segmentnext-core-js'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/wp-embed.min.js?ver=1611674313' id='wp-embed-js'></script>

				<!-- Taboola -->
		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});
		</script>
		
				<!-- Amazon ONELINK -->
		<div id="amzn-assoc-ad-2580c1b4-326e-4bc3-bdd1-7d87dd55ec7b"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=2580c1b4-326e-4bc3-bdd1-7d87dd55ec7b"></script>
		
			</body>
</html>
