<!doctype html>
<html lang="en-US">
	<head>
		<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="http://gmpg.org/xfn/11">
		
	<!-- This site is optimized with the Yoast SEO Premium plugin v14.7 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Warner Bros. Montreal’s Batman Game Confirmed For DC FanDome | SegmentNext</title>
	<meta name="description" content="The official schedule of DC FanDome has confirmed that Warner Bros. Games Montreal is finally ready to announce the new Batman game." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Warner Bros. Montreal’s Batman Game Confirmed For DC FanDome | SegmentNext" />
	<meta property="og:description" content="The official schedule of DC FanDome has confirmed that Warner Bros. Games Montreal is finally ready to announce the new Batman game." />
	<meta property="og:url" content="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/" />
	<meta property="og:site_name" content="SegmentNext" />
	<meta property="article:publisher" content="http://facebook.com/segmentnext" />
	<meta property="article:published_time" content="2020-08-14T15:14:55+00:00" />
	<meta property="og:image" content="https://cdn.segmentnext.com/wp-content/uploads/2020/08/Batman-Arkham-Knight-City-Scapes.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@https://twitter.com/wearyscribe" />
	<meta name="twitter:site" content="@segmentnext" />
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SegmentNext &raquo; Feed" href="https://segmentnext.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SegmentNext &raquo; Comments Feed" href="https://segmentnext.com/comments/feed/" />
			<meta property="og:title" content="Warner Bros. Montreal’s Batman Game Confirmed For DC FanDome">
			<meta property="og:type" content="article">
			<meta property="og:url" content="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/">
			<meta property="og:site_name" content="SegmentNext">
							<meta property="og:description" content="Gaming News, Reviews, PC Hardware and eSports">
							<meta property="og:image" content="https://cdn.segmentnext.com/wp-content/uploads/2020/08/Batman-Arkham-Knight-City-Scapes.jpg">
			<link rel="alternate" type="application/rss+xml" title="SegmentNext &raquo; Warner Bros. Montreal’s Batman Game Confirmed For DC FanDome Comments Feed" href="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdn.segmentnext.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=1572991442"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='segment-next-style-css'  href='https://cdn.segmentnext.com/wp-content/themes/segmentnext/style.css?ver=1596424812' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.segmentnext.com/wp-includes/css/dist/block-library/style.min.css?ver=1587742334' type='text/css' media='all' />
<link rel='stylesheet' id='aksile-silo-css'  href='https://cdn.segmentnext.com/wp-content/plugins/aksile-silo/public/css/aksile-silo-public.css?ver=1596424812' type='text/css' media='all' />
<link rel='stylesheet' id='segmentnext-core-css'  href='https://cdn.segmentnext.com/wp-content/plugins/segmentnext-core/public/css/segmentnext-core-public.css?ver=1596424812' type='text/css' media='all' />
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/jquery/jquery.js?ver=1558067154'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1463724688'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-content/plugins/aksile-silo/public/js/aksile-silo-public.js?ver=1596424812'></script>
<link rel='https://api.w.org/' href='https://segmentnext.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://segmentnext.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.segmentnext.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://segmentnext.com/?p=672499' />
<link rel="alternate" type="application/json+oembed" href="https://segmentnext.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsegmentnext.com%2F2020%2F08%2F14%2Fwarner-bros-montreals-batman-game-dc-fandome%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://segmentnext.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsegmentnext.com%2F2020%2F08%2F14%2Fwarner-bros-montreals-batman-game-dc-fandome%2F&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://segmentnext.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/' + 'LhfdY3JSwVQ8' + '.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script><!-- Google Analytics -->
<script type="text/javascript">
	(function (i, s, o, g, r, a, m) {
		i['GoogleAnalyticsObject'] = r;
		i[r] = i[r] || function () {
			(i[r].q = i[r].q || []).push(arguments)
		}, i[r].l = 1 * new Date();
		a = s.createElement(o),
				m = s.getElementsByTagName(o)[0];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore(a, m)
	})(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');

	ga('create', 'UA-4104257-2', 'auto');
	  ga('set', 'dimension1', 'saqib');
  ga('set', 'dimension2', 'News');
	ga('send', 'pageview');
</script>
<!-- /Google Analytics -->

<!-- Yandex.Metrika counter -->
<script type="text/javascript" >
	(function (d, w, c) {
		(w[c] = w[c] || []).push(function() {
			try {
				w.yaCounter50618239 = new Ya.Metrika2({
					id:50618239,
					clickmap:true,
					trackLinks:true,
					accurateTrackBounce:true,
					webvisor:true
				});
			} catch(e) { }
		});

		var n = d.getElementsByTagName("script")[0],
			s = d.createElement("script"),
			f = function () { n.parentNode.insertBefore(s, n); };
		s.type = "text/javascript";
		s.async = true;
		s.src = "https://mc.yandex.ru/metrika/tag.js";

		if (w.opera == "[object Opera]") {
			d.addEventListener("DOMContentLoaded", f, false);
		} else { f(); }
	})(document, window, "yandex_metrika_callbacks2");
</script>
<noscript><div><img src="https://mc.yandex.ru/watch/50618239" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<!-- /Yandex.Metrika counter -->
			<script type="text/javascript" async=true>var elem = document.createElement("script"); elem.src = "https://quantcast.mgr.consensu.org/cmp.js"; elem.async = !0; elem.type = "text/javascript"; var scpt = document.getElementsByTagName("script")[0]; scpt.parentNode.insertBefore(elem, scpt); (function(){function d(){if (!window.frames.__cmpLocator)if (document.body){var b = document.body, a = document.createElement("iframe"); a.style = "display:none"; a.name = "__cmpLocator"; b.appendChild(a)} else setTimeout(d, 5)}function c(b){var a = "string" === typeof b.data; var c = a? - 1 != b.data.indexOf("__cmpCall")?JSON.parse(b.data):{}:b.data; if (c.__cmpCall){var e = c.__cmpCall; window.__cmp(e.command, e.parameter, function(c, d){var f = {__cmpReturn:{returnValue:c, success:d, callId:e.callId}}; b.source.postMessage(a?JSON.stringify(f):f, "*")})}}d(); window.__cmp = function(b){var a = arguments; if (a.length)if ("ping" === a[0])a[2]({gdprAppliesGlobally:!1, cmpLoaded:!1}, !0);  else{if ("__cmp" == b)return!1; "undefined" === typeof __cmp.a && (__cmp.a = []); __cmp.a.push([].slice.apply(a))} else return __cmp.a}; window.__cmp.gdprAppliesGlobally = !1; window.__cmp.msgHandler = c; window.addEventListener?window.addEventListener("message", c, !1):window.attachEvent("onmessage", c)})(); window.__cmp("init", {Language:"en", "Display Persistent Consent Link":false, "Initial Screen Reject Button Text":"I do not accept", "Initial Screen Accept Button Text":"I accept", "Purpose Screen Header Title Text":"Privacy settings", "Purpose Screen Body Text":"You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.", "Vendor Screen Body Text":"You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.", "Vendor Screen Accept All Button Text":"Accept all", "Vendor Screen Reject All Button Text":"Reject all", "Initial Screen Body Text":"We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.", "Initial Screen Body Text Option":1, "Publisher Name":"SegmentNext", "Publisher Logo":"https://cdn.segmentnext.com/wp-content/uploads/2018/06/sn-cmp.png", "Min Days Between UI Displays":5, "Consent Scope":"service", "No Option":!1, "Default Value for Toggles":"on"});</script><style>.qc-cmp-publisher-logo{padding-top: 10px !important;}.qc-cmp-ui-content{padding-top: 10px !important;}.qc-cmp-alt-buttons{padding-bottom:30px !important;}.qc-cmp-ui-content {padding-bottom:30px !important;}.qc-cmp-title{font-size:30px!important;}.qc-cmp-link-text{display:none !important}.qc-cmp-qc-link{display:none !important}</style>
				<!-- Venatus Ad Manager - Install in <HEAD> of page -->
		<script>
		(function() {
		document.write('<div id="vmv3-ad-manager" style="display:none"></div>');
		document
		.getElementById("vmv3-ad-manager")
		.innerHTML = '<iframe id="vmv3-frm" src="javascript:\'<html><body></body></html>\'" width="0" height="0" data-mode="scan" data-site-id="5e3bdf5b48105f3605472aeb"></iframe>';
		var loaderFrame = document.getElementById("vmv3-frm");
		var loaderFrameWindow = loaderFrame.contentWindow ? loaderFrame.contentWindow : loaderFrame.contentDocument;
		loaderFrameWindow.document.open();
		loaderFrameWindow.document.write('<scr'+'ipt src="https://hb.vntsm.com/v3/live/ad-manager.min.js" type="text/javascript" async>'+'</scr'+'ipt>');
		loaderFrameWindow.document.close();
		})();
		</script>
		<!-- Venatus Ad Manager -->
				<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
		<script>
			var googletag = googletag || {};
			googletag.cmd = googletag.cmd || [];
		</script>
			<script>
			</script>

	<!-- Taboola -->
	<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
		if (!document.getElementById(i)){
		e.async = 1;
		e.src = u;
		e.id = i;
		f.parentNode.insertBefore(e, f);
		}
		}(document.createElement('script'),
				document.getElementsByTagName('script')[0],
				'//cdn.taboola.com/libtrc/segmentnext/loader.js',
				'tb_loader_script');
		if (window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic'); }
	</script>
		<!-- Blockthrough Integration -->
	<script src="https://segmentnext-com.videoplayerhub.com/videoloader.js"></script>
	<link rel="amphtml" href="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/amp/"><link rel="icon" href="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn.segmentnext.com/wp-content/uploads/2018/05/cropped-favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.carousel-num { width: 100px; }		</style>
		<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "NewsArticle",
    "headline": "Warner Bros. Montreal\u2019s Batman Game Confirmed For DC FanDome",
    "image": "https:\/\/cdn.segmentnext.com\/wp-content\/uploads\/2020\/08\/Batman-Arkham-Knight-City-Scapes.jpg",
    "datePublished": "2020-08-14",
    "dateModified": "2020-08-14",
    "description": "Warner Bros. Games Montreal has been teasing a new Batman game for months now. The developer had to even ask fans to be patient and that an announcement will be made when the game has been deemed ready. That time is now here.According to the\u00a0official",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "id": "https:\/\/segmentnext.com\/2020\/08\/14\/warner-bros-montreals-batman-game-dc-fandome\/"
    },
    "author": {
        "@type": "Person",
        "name": "Saqib Mansoor"
    },
    "publisher": {
        "@type": "Organization",
        "name": "SegmentNext",
        "url": "https:\/\/segmentnext.com",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/cdn.segmentnext.com\/wp-content\/uploads\/2020\/01\/cropped-segment-next.png"
        }
    }
}</script>
	</head>
	<body class="post-template-default single single-post postid-672499 single-format-standard wp-custom-logo">
		<div id="page" class="site">
			<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
			<header id="masthead" class="site-header">
				<nav id="site-navigation" class="navbar navbar-default">
					<div class="container-fluid">
						<!-- Brand and toggle get grouped for better mobile display -->
						<div class="navbar-header">
							<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#primary-navbar-collapse" aria-expanded="false">
								<i class="icon icon-menu"></i>
								<i class="icon icon-close"></i>
							</button>
							<div class="search-container mobile hidden-lg">
								<div class="search-box">
									<form role="search" method="get" id="search-form" action="https://segmentnext.com/">
										<div class="input-group">
											<input type="text" name="s" class="form-control search-field" placeholder="Search &hellip;" aria-describedby="sizing-addon1">
											<span class="input-group-btn">
												<button class="navbar-search go" type="submit"><i class="icon icon-enter"></i></button>
												<button class="navbar-search open-search" type="button"><i class="icon icon-search"></i></button>
											</span>
										</div>
									</form>
								</div>
							</div>
							<a href="https://segmentnext.com/" class="navbar-brand" rel="home"><img width="395" height="70" src="https://cdn.segmentnext.com/wp-content/uploads/2020/01/cropped-segment-next.png" class="custom-logo" alt="SegmentNext" /></a>						</div>
						<!-- Collect the nav links, forms, and other content for toggling -->
						<div class="collapse navbar-collapse" id="primary-navbar-collapse">
							<ul id="menu-header-navbar-left" class="nav navbar-nav"><li><a title="News" target="_blank" href="https://segmentnext.com/topics/news/">News</a></li>
<li><a title="Reviews" target="_blank" href="https://segmentnext.com/topics/reviews/">Reviews</a></li>
<li><a title="Computer Hardware" target="_blank" href="https://segmentnext.com/topics/computer-hardware/">Computer Hardware</a></li>
</ul>														<a href="https://segmentnext.com/topics/deals/" class="btn btn-sm btn-transparent btn-block navbar-btn visible-xs visible-sm btn-ghost-dark fill-animate ghost-fill shutter-horizontal">Best Deals</a>
														<div class="nav navbar-nav navbar-right search-container visible-lg">
								<div class="search-box">
									<form role="search" method="get" id="search-form" action="https://segmentnext.com/">
										<div class="input-group">
											<input type="text" name="s" class="form-control search-field" placeholder="Search &hellip;" aria-describedby="sizing-addon1">
											<span class="input-group-btn">
												<button class="navbar-search go" type="submit"><i class="icon icon-enter"></i></button>
												<button class="navbar-search open-search" type="button"><i class="icon icon-search"></i></button>
											</span>
										</div>
									</form>
								</div>
							</div>
														<a href="https://segmentnext.com/topics/deals/" class="btn btn-sm btn-transparent navbar-btn navbar-btn-desktop navbar-right hidden-xs hidden-sm btn-ghost-dark fill-animate ghost-fill shutter-horizontal">Best Deals</a>
							
							<ul id="menu-header-top-menu" class="nav navbar-nav navbar-right extra-links"><li><a title="Esports" target="_blank" href="https://segmentnext.com/topics/esports/">Esports</a></li>
<li><a title="Pop Culture" target="_blank" href="https://segmentnext.com/topics/pop-culture/">Pop Culture</a></li>
</ul>							<ul class="nav navbar-nav navbar-right social-icons">
								<li><a href="https://twitter.com/@segmentnext" target="_blank"><i class="icon icon-twitter-circle"></i></a></li>
								<li><a href="https://facebook.com/SegmentNext" target="_blank"><i class="icon icon-facebook-circle"></i></a></li>
								<li><a href="https://www.youtube.com/user/segmentnext" target="_blank"><i class="icon icon-youtube"></i></a></li>
							</ul>
						</div><!-- /.navbar-collapse -->
					</div><!-- /.container-fluid -->
				</nav><!-- #site-navigation -->
			</header><!-- #masthead -->

			
			<div id="content" class="site-content">
				<div class="container">
		<div class="ad-atf-top single">
		<!-- segmentnext.com - 728x90 Dynamic (5e3be75e48105f3605472aed) - 728x90, 970x250, 970x90 - Place in <BODY> of page where ad should appear -->
		<div class="vm-placement" data-id="5e3be75e48105f3605472aed"></div>
		<!-- / segmentnext.com - 728x90 Dynamic (5e3be75e48105f3605472aed) -->
	</div>
	
		<div class="visible-sm visible-md visible-lg"><ul class="breadcrumb"><li><a href="https://segmentnext.com/topics/news/">News</a></li></ul></div>
	
			<h1 class="entry-title desktop visible-sm visible-md visible-lg">Warner Bros. Montreal’s Batman Game Confirmed For DC FanDome</h1>	
	<div class="row">
		<div class="col-md-8">
			<div id="primary" class="content-area">
				<main id="main" class="site-main">

					
					<div class="feature-image hidden-xs">
    			<div class="post-thumbnail">
				<img width="1280" height="720" src="https://cdn.segmentnext.com/wp-content/uploads/2020/08/Batman-Arkham-Knight-City-Scapes.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://cdn.segmentnext.com/wp-content/uploads/2020/08/Batman-Arkham-Knight-City-Scapes.jpg 1280w, https://cdn.segmentnext.com/wp-content/uploads/2020/08/Batman-Arkham-Knight-City-Scapes-600x338.jpg 600w, https://cdn.segmentnext.com/wp-content/uploads/2020/08/Batman-Arkham-Knight-City-Scapes-983x553.jpg 983w, https://cdn.segmentnext.com/wp-content/uploads/2020/08/Batman-Arkham-Knight-City-Scapes-768x432.jpg 768w" sizes="(max-width: 1280px) 100vw, 1280px" />			</div><!-- .post-thumbnail -->
		    
</div>

<article id="post-672499" class="post-672499 post type-post status-publish format-standard has-post-thumbnail category-news tag-warner-bros-montreal">
    <div class="entry-item-container">
        <header class="entry-header visible-sm visible-md visible-lg">
                <div class="entry-meta">
        <span class="byline"> By <span class="author"><a class="url fn n" href="https://segmentnext.com/author/saqib/">Saqib Mansoor</a></span></span><span class="posted-on"><a href="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/" rel="bookmark"><time class="entry-date published updated" datetime="2020-08-14T20:14:55+05:00" itemprop="datePublished">Aug 14, 2020</time></a></span>        <span class="share dropdown">
            <a href="javascript:void(0);" class="btn btn-xs btn-primary fill-animate default-fill shutter-horizontal dropdown-toggle shareBtn" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false" aria-labelledby="dropdownMenu1"><span class="icon icon-share"></span> Share</a>
            <div class="dropdown-menu share-box dropdown-menu-right">
                <div class="top-section">
                    <h6>Share</h6>
                                        <ul class="list-inline mb-0 px-0">
                        <li class="list-item"><a target="_blank" href="http://www.facebook.com/share.php?u=https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/" class="share-link facebook"><i class="icon icon-facebook"></i></a></li>
                        <li class="list-item"><a target="_blank" href="http://twitter.com/home?status=Warner%20Bros.%20Montreal%E2%80%99s%20Batman%20Game%20Confirmed%20For%20DC%20FanDome - https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/" class="share-link twitter"><i class="icon icon-twitter"></i></a></li>
                        <li class="list-item"><a target="_blank" href="http://reddit.com/submit?url=https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/&#038;title=Warner%20Bros.%20Montreal%E2%80%99s%20Batman%20Game%20Confirmed%20For%20DC%20FanDome" class="share-link redit"><i class="icon icon-redit"></i></a></li>
                        <li class="list-item"><a target="_blank" href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/&#038;title=Warner%20Bros.%20Montreal%E2%80%99s%20Batman%20Game%20Confirmed%20For%20DC%20FanDome" class="share-link linkdin"><i class="icon icon-linkedin-open"></i></a></li>   
                    </ul>
                </div>
                <div class="mid-section">
                    <input class="form-control" type="text" value="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/" placeholder="link ..." id="copyInput" autofocus="autofocus" onfocus="this.select()" readonly=""/>
                </div>
                <div class="bottom-section clearfix">
                    <button class="btn btn-link btn-sm pull-right copy-permalink" type="button" id="copyID">Copy</button>
                </div>
            </div>
        </span>
    </div>
        </header><!-- .entry-header -->
        <div class="entry-content">
                        
            <p>Warner Bros. Games Montreal has been teasing a new Batman game for months now. The developer had to even <a href="https://segmentnext.com/2020/05/14/warner-bros-montreal-new-batman-game-announcement-come-theyre-ready/" rel="noopener noreferrer" target="_blank">ask fans to be patient</a> and that an announcement will be made when the game has been deemed ready. That time is now here.</p>
<p>According to the <a href="https://schedule.dcfandome.com/category/a3d74425-f0c4-48f0-bb33-13a62e1379e5" target="_blank" rel="noopener noreferrer">official schedule</a> of the upcoming DC FanDome event, Warner Bros. Games Montreal will be hosting a developer panel to not only announce the new Batman game but also answer questions that fans might have. </p>
<blockquote><p>August 22 / 1:30 p.m. ET &#8211; Warner Bros. Montreal Game Announcement.</p>
<p>Gamers! You won’t want to miss this first look at an exciting new game, and Q&#038;A with its developers.</p></blockquote>
<p>Warner Bros. Games Montreal has been <a href="https://segmentnext.com/2019/12/18/batman-arkham-legacy-current-gen-only/" rel="noopener noreferrer" target="_blank">rumored to be working</a> on a new Batman game for past couple of years at least. Several names have come up during this time such as Batman: Arkham Legacy and Batman: Arkham Universe, but those could possibly be placeholders. The only thing for certain is that the new Batman game will feature the Court of Owls, an ancient and secretive group that has been controlling Gotham City from the shadows for centuries.</p>
<p>Warner Bros. Games Montreal was previously behind Batman: Arkham Origins and the post-release content for Batman: Arkham Knight. There have been strong reports that the new Batman game will <a href="https://segmentnext.com/2020/02/05/new-batman-game-reboot/" rel="noopener noreferrer" target="_blank">serve as a soft reboot</a> for the Batman: Arkham trilogy. There have been just too many rumors and reports to consider. Why the announcement was held off for so long remains to be known, but fans will be glad regardless that their patience gets to be rewarded soon.  </p>
<p>DC FanDome will take place on August 22 as a digital event due to COVID-19. The show will run straight for 24 hours and hence, those interested in tuning in should check out the complete schedule to know exactly when and what to stream. </p>
			
            <!--
            <section class="social-share visible-xs btm">
                <ul>
                    <li><h6>Share This:</h6></li>
                    <li><a target="_blank" href="http://www.facebook.com/share.php?u=" class="share-link facebook"><i class="icon icon-facebook"></i></a></li>
                    <li><a target="_blank" href="http://twitter.com/home?status= - " class="share-link twitter"><i class="icon icon-twitter"></i></a></li>
                    <li><a target="_blank" href="http://reddit.com/submit?url=&#038;title=" class="share-link redit"><i class="icon icon-redit"></i></a></li>
                    <li><a target="_blank" href="http://www.linkedin.com/shareArticle?mini=true&#038;url=&#038;title=" class="share-link linkdin"><i class="icon icon-linkedin-open"></i></a></li>
                </ul>
            </section>
            -->
                    </div><!-- .entry-content -->
    </div>
    </article><!-- #post-672499 -->
						
						<!-- code from Primis - Segment - SegmentNext Desktop -->
						<script type="text/javascript" language="javascript" src="https://live.sekindo.com/live/liveView.php?s=98306&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&subId=[SUBID_ENCODED]&x=[WIDTH]&y=[HEIGHT]&vp_content=plembedb75wuigsozmk"></script><!-- code from Primis -->

						
						
												<div id="taboola-below-article-thumbnails"></div>
						<script type="text/javascript">
							window._taboola = window._taboola || [];
							_taboola.push({
								mode: 'thumbnails-a',
								container: 'taboola-below-article-thumbnails',
								placement: 'Below Article Thumbnails',
								target_type: 'mix'
							});
						</script>
										</main><!-- #main -->
			</div><!-- #primary -->
		</div><!-- .col-md-8 -->
		<div class="col-md-4">
			<aside id="secondary" class="widget-area" role="complementary">
        <section id="segmentnext_widget_desktop_ad-6" class="widget widget_segmentnext"><!-- segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) - 300x250, 300x600, 160x600 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e3be77b48105f3605472af1"></div>
<!-- / segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) --></section><section id="segmentnext_widget-9" class="widget widget_segmentnext"><h4 class="widget-title"><span class="widget-title-before"><span class="widget-title-after">Reviews</span></span></h4>		<ul>
						<li>
				<a href="https://segmentnext.com/2020/07/24/f1-2020-review/">
										F1 2020 Review &#8211; A New Standard in Racing Simulation				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/07/23/death-stranding-pc-review/">
										Death Stranding PC Review				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/06/12/desperados-3-review/">
										Desperados 3 Review &#8211; The Wild Bunch				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/03/12/ori-and-the-will-of-the-wisps-review-a-ku-lossal-improvement/">
										Ori and the Will of the Wisps Review &#8211; A Ku-lossal Improvement				</a>
			</li>
								</ul>
		</section><section id="segmentnext_widget_desktop_ad-7" class="widget widget_segmentnext"><!-- segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) - 300x250, 300x600, 160x600 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e3be77b48105f3605472af1"></div>
<!-- / segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) --></section><section id="segmentnext_widget-10" class="widget widget_segmentnext"><h4 class="widget-title"><span class="widget-title-before"><span class="widget-title-after">Originals</span></span></h4>		<ul>
						<li>
				<a href="https://segmentnext.com/2020/08/06/assassins-creed-valhalla-assaults-epic-viking-moments/">
										Assassin&#8217;s Creed Valhalla&#8217;s Assaults Are &#8220;Epic Viking Moments,&#8221; Each Will &#8220;Feel Unique&#8221;				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/08/04/assassins-creed-valhalla-respec/">
										Assassin&#8217;s Creed Valhalla Will Allow Eivor To Respec Their Skill Trees				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/08/04/where-the-heart-is-choices-playthroughs/">
										Where The Heart Is Offers Rich Palette Of Choices, Multiple Playthroughs, Consequential Storytelling				</a>
			</li>
						<li>
				<a href="https://segmentnext.com/2020/07/29/assassins-creed-valhalla-charisma/">
										Assassin&#8217;s Creed Valhalla&#8217;s Charisma Will Open New Narrative Choices For Different Outcomes				</a>
			</li>
								</ul>
		</section><section id="segmentnext_widget_desktop_ad-8" class="widget widget_segmentnext"><!-- segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) - 300x250, 300x600, 160x600 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e3be77b48105f3605472af1"></div>
<!-- / segmentnext.com - 300x250 Dynamic (5e3be77b48105f3605472af1) --></section>		<section id="recent-posts-2" class="widget widget_recent_entries">		<h4 class="widget-title"><span class="widget-title-before"><span class="widget-title-after">In the News</span></span></h4>		<ul>
											<li>
					<a href="https://segmentnext.com/2020/08/14/cyberpunk-2077-all-three-lifepaths/">Cyberpunk 2077 Fans Are Split Between All Three Lifepaths</a>
									</li>
											<li>
					<a href="https://segmentnext.com/2020/08/14/warner-bros-montreals-batman-game-dc-fandome/" aria-current="page">Warner Bros. Montreal’s Batman Game Confirmed For DC FanDome</a>
									</li>
											<li>
					<a href="https://segmentnext.com/2020/08/14/suicide-squad-game-kill-the-justice-league/">Suicide Squad Game Will Task You To Kill The Justice League</a>
									</li>
											<li>
					<a href="https://segmentnext.com/2020/08/14/xbox-series-x-next-gen-console-war/">Xbox Series X Will Not Be Part Of A Next-Gen Console War, Says Spencer</a>
									</li>
					</ul>
		</section>    </aside><!-- #secondary -->		</div><!-- .col-md-4 -->
	</div><!-- .row -->
</div><!-- .container -->
						</div><!-- #content -->
			<footer id="colophon" class="site-footer">
				<div class="container">
					<div class="row">
						<div class="col-md-8">
							<div class="logo-footer"><img src="https://cdn.segmentnext.com/wp-content/themes/segmentnext/images/segment-next.png" alt="SegmentNext" /></div>
							<div class="menu-footer">
								<h6 class="text-uppercase">Aksile Media</h6>
								<div class="menu-footer-menu-2-container"><ul id="footer-menu" class="menu"><li id="menu-item-421461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-421461"><a target="_blank" rel="nofollow" href="https://segmentnext.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-436385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-436385"><a target="_blank" rel="nofollow" href="https://segmentnext.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-436387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-436387"><a target="_blank" rel="nofollow" href="https://segmentnext.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-421463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-421463"><a target="_blank" rel="nofollow" href="https://segmentnext.com/contact-us/">Contact</a></li>
<li id="menu-item-446331" class="change-ad-consent menu-item menu-item-type-custom menu-item-object-custom menu-item-446331"><a rel="nofollow" href="#.">Change Ad Consent</a></li>
</ul></div>							</div>
							<div class="site-info">
								&copy; 2018 SegmentNext. All rights reserved.							</div><!-- .site-info -->
						</div><!-- #col-md-8 -->
						<div class="col-md-4">
							<div class="footer-right">
								<!--
									<h6 class="text-uppercase">< ?php _e('Stay Updated', 'segmentnext'); ?></h6>
									<h2>< ?php _e('SegmentNext Daily', 'segmentnext'); ?></h2>
									<p>< ?php _e('Signup for video game news, reviews and best gaming deals.', 'segmentnext'); ?></p>
								-->
								<h6 class="text-uppercase">Connect With Us</h6>

								<ul class="nav navbar-nav footer-socials social-icons">
									<li><a href="https://twitter.com/@segmentnext" target="_blank"><i class="icon icon-twitter-circle"></i></a></li>
									<li><a href="https://facebook.com/SegmentNext" target="_blank"><i class="icon icon-facebook-circle"></i></a></li>
									<li><a href="https://www.youtube.com/user/segmentnext" target="_blank"><i class="icon icon-youtube"></i></a></li>
								</ul>
							</div>
						</div><!-- #col-md-4 -->
					</div><!-- #row -->
				</div>
			</footer><!-- #colophon -->
		</div><!-- #page -->
	<!-- segmentnext.com - Rich Media AP (5e590016db8f36673d6188b1) - 1x1 - Place in <BODY> of page where ad should appear -->
<div class="vm-placement" data-id="5e590016db8f36673d6188b1" style="display:none"></div>
<!-- / segmentnext.com - Rich Media AP (5e590016db8f36673d6188b1) -->
	<script type='text/javascript'>
/* <![CDATA[ */
var global_var = {"ajaxurl":"https:\/\/segmentnext.com\/wp-admin\/admin-ajax.php","siteurl":"https:\/\/segmentnext.com\/wp-content\/themes\/segmentnext","nonce":"1a3fd9f203","posts":"{\"page\":0,\"year\":2020,\"monthnum\":8,\"day\":14,\"name\":\"warner-bros-montreals-batman-game-dc-fandome\",\"error\":\"\",\"m\":\"\",\"p\":0,\"post_parent\":\"\",\"subpost\":\"\",\"subpost_id\":\"\",\"attachment\":\"\",\"attachment_id\":0,\"pagename\":\"\",\"page_id\":0,\"second\":\"\",\"minute\":\"\",\"hour\":\"\",\"w\":0,\"category_name\":\"\",\"tag\":\"\",\"cat\":\"\",\"tag_id\":\"\",\"author\":\"\",\"author_name\":\"\",\"feed\":\"\",\"tb\":\"\",\"paged\":0,\"meta_key\":\"\",\"meta_value\":\"\",\"preview\":\"\",\"s\":\"\",\"sentence\":\"\",\"title\":\"\",\"fields\":\"\",\"menu_order\":\"\",\"embed\":\"\",\"category__in\":[],\"category__not_in\":[],\"category__and\":[],\"post__in\":[],\"post__not_in\":[],\"post_name__in\":[],\"tag__in\":[],\"tag__not_in\":[],\"tag__and\":[],\"tag_slug__in\":[],\"tag_slug__and\":[],\"post_parent__in\":[],\"post_parent__not_in\":[],\"author__in\":[],\"author__not_in\":[],\"ignore_sticky_posts\":false,\"suppress_filters\":false,\"cache_results\":false,\"update_post_term_cache\":true,\"lazy_load_term_meta\":true,\"update_post_meta_cache\":true,\"post_type\":\"\",\"posts_per_page\":25,\"nopaging\":false,\"comments_per_page\":\"100\",\"no_found_rows\":false,\"order\":\"DESC\"}","current_page":"1","max_page":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-content/themes/segmentnext/js/sn-scripts.js?ver=1596424812'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/comment-reply.min.js?ver=1573473063'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-content/plugins/segmentnext-core/public/js/segmentnext-core-public.js?ver=1596424812'></script>
<script type='text/javascript' src='https://cdn.segmentnext.com/wp-includes/js/wp-embed.min.js?ver=1572049027'></script>

				<!-- Taboola -->
		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});
		</script>
		
				<!-- Amazon ONELINK -->
		<div id="amzn-assoc-ad-2580c1b4-326e-4bc3-bdd1-7d87dd55ec7b"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=2580c1b4-326e-4bc3-bdd1-7d87dd55ec7b"></script>
		
			</body>
</html>
